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Unit 1: Digital Documentation (Advanced)

Assignmem 1

Objective: Using various commands to create customer styles and apply predefined styles in
LibreOftice Wniter.

Task: Type a paragraph with at least 100 words and create below given styles as instructed:
1. Title

a. Font Name: Knsten ITC. Size:28, Colour: Magenta

b. Give Style Name: Title Al (Use create styles using drag and drop)
2. Headings

a. Font name: Times New Roman, Size: 24 , Colour: Red.

b. Give the style name: My Heading (Use create style from selection command)

3. Paragraph and Headings - My heading styles to all headings using Fill Format
4. Load Styles in New Document and Save the document

Eg!uﬂun:

Preparing document

1. Click on Start > All Apps > LibreOffice 24.2 > LibreOffice Writer.

2. Type required text.

Creating styles
=

L b

Title (Using Drag and Drop)

. Select the title “Generative Artificial Intelligence™.

Apply the desired formatting,
Now click on Styles > Manage Styles option.
Select the title “Generative Artificial Intelligence™ and darg over the Styles pane present

on the screen.

. New Style From Selection dialog box will appear with a prompt to enter New Style

Name. Type name as “Title AI”.
Click on OK button.
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Headings (Create Style using New Style from Selection option)

. Select first heading — “Introduction™.

Apply the desired formatting for style as per instructions given in the question.
Click on Styles > Manage Styles option. A styles pane will appear.

Click on Style Actions button and choose New Style From Selection option.

New Style from Selection dialog box appears. Type Style name as — *“My Heading™.
Click on OK.

Applying Styles

~ Using double click

1.

Z;
3.

Select the heading “Technology™.
Now Find the newly created styles “My Heading™.
Double Click on it.

~ Using Fill Format
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Click on Fill Format icon on Styles pane.

A fill format mode will be activated and mouse cursor changes to Fill Format mode 1con.
Select “My Heading” style from Styles pane.

Drag it over to the headings to apply *My Heading™ style.

Save the file as “Practical | — Create and apply styles™.

Load styles

. Open new blank document.

Activate Styles pane from side bar or any other option.

Click on Style Actions button and choose “Load Styles from Template™.
Find the button From File and click on it.

Choose the previously saved file.

Click on Open button.

The styles from selected document will be added into the Style gallery.
Save the file.




Output Document:

Generative ArtifiCial Intelligence
Introduction

Generative Al refers to artificial inte!ligence systems designed to create new content, rangirg from
text and images to music and video.

Technology

These systems leverage advanced machine learcing rechniques, such as newal networks and deep
leaming, o analyze vast datasets and generate outputs that mimic hurman creativity.,

Applications

Generative Al finds ase in diverse fields, including ertertainment, where it can produce art, and in
business, where it can automate content creatior and enhance costomer inferactions.

Ethics

ITowever, its capabilities 1aise ethical concerns regarding originality, misinformadon, and the
potential lor misuse, necessitating ongoing scrwtiny and r!guiaa‘.innj




Assignment 2

Objective: Inserting umages and shapes and rearranging them

Task: Create a new document mn LibreOffice prepare an advertisement using various
shapes and images.

Solution:
Add Page background

1. Open LibreOffice Writer and Background from Format > Page Style > Area > Gradient,
2. Choose Sundown gradient for page background and Click on Apply and OK.

Add Page border

1. Click on Format > Page Style > Borders.
2. Click on All four borders option.

3. Choose the line style from Style.

4. Click on Apply and OK button.

Add font work (Learn Coding)

Click on View = Toolbar > Drawing.

. Click on Insert Font Text icon from the Drawing Toolbar.
Select Gold Wave style.

Type the text Learn Coding and change color.

. Press enter when you fimshed.

Add font work (For 3 to 12 Class Students)

1. Click on Insert Font Text icon from the Drawing Toolbar.
2. Select relevant style for Font Text.

3. Type the desired text and change the color.

4. Press enter when you finished.

Insert Image

LA b b bd =

. Place the cursor where image is required.

Click Insert > Image option. An Insert Image dialog box will appear.
Select the image from the dialog box.

. Click on open button.

Applying border to image

T

1. Select an image to apply border.
2. Click on Borders 1con on the Image toolbar and select Outer Border (Ouly).

Add Textbox to insert courses

1. Select rectangle box from Drawing toolbar.
2. Draw the rectangle in the document.




Applying backeround colour to box

1. Select the box.

2. Choose the Fill Colour icon from drawing properties toolbar.
3. Select Yellow color from the Fill Colour icon.
4

. Add the desired text.
Similarly add remaining shapes, apply the desired formatting and text. Save the file,
Output:

L+

Java

Python

Excel

Web Development
App Development
Game Development

Call us:
E-Learn Coding Institute 12345 67890
B-13, Radhe Complex
Satellite, Ahmedabad




Assignment 3

Objective: Creating templates in LibreOffice Writer and savmng for distribution.
Task:

* Prepare a template for the class time table.

= Apply formatting as required.

» Set this template as a default template,

= Reset the default template as usual.

Solution:

1. Create a new document in LibreOffice Writer.

2. Click on Format = Page Stvle option,

3. A page style dialog box will appear.

4. Select Area > Image > Add/Import option.

5. Apply desired options for background and click on OK button.
6. Insert table for time table and format it as per your choice.
Saving file as template

1. Click on File = Templates > Save as Template option.
A Save As Template dialog box will appear.
“Time Table * as Template Name in Enter Template Name dialog box.
Select Template Category as MyTemplate.
Click on Set as default template option.
Click on Save button.

=i O

Reset default template

1. Click on File > Templates > Manage Templates option.
2. A manage template dialog box wall appear.

3. Click on Manage > Reset Default Text Document option.
4. Click on Close button.




Class Time Ta])le

." JdMon Tue Wed Thu Fri Sat '_




Assignment 4

Objective: Create and Customize Table of Contents
Task: Prepare a document with different headings and apply a table of contents to it.

Solution:

1. Type the contents.

2. Apply appropnate level of headings from the Styles window.

3. Place the cursor at the beginning of document to insert Table of Content.

4. Click on Insert — Table of contents and index — Table of contents. index or Bibliography
option. The Table of contents. index or Bibliography will appear.

5. Select and apply the styles for the Table of Contents.

3. Chick on OK.

Qutput




Assignment 5

Objective: Customize the table of contents

Task: Apply customization following customization on above Table of contents:
1. Apply heading levels up to 3

2. Divide Table of contents into two parts vertically

3. Add a background colour of your choice

Solution:
1. Select the Table of Contents created in previous question.
2. Select Type tab.

3. Find the option include level upto and select 3.

4. Click on Columns tab.

5. Set 2 in the Columns.

6. Click on Background tab.

7. Click on Colour button.

8. Pick the desired colour to apply as background.

9. Click on OK button.

QOutput:




Unit 2: Electronic Spreadsheet (Advanced)

Assignment 1

Objective: Applyving Data Consolidation i LibreOffice Cale
Task: Prepare 3 worksheets for products sales and consolidate them

Solution:

Preparing sheets for Data Consolidation
1.
2,
3

4.

Create a new file m spreadsheet software and enter data for 5 products.

Add two worksheets in the file and modify the data for all. Click on Sheet tab and + icon there,
Rename all worksheets like sheet] - Ahmedabad. sheet - Surat and sheet3 - Rajkot. Select
the sheets respectively and do nght click on Sheet tab > Rename Sheet option. Type the sheet
name and Click on OK button.

Now add one more worksheet at the end and rename as Consolidated as similar as step 2 and 3.

Perform Data Consolidation

1. Place the cursor in cell B2 in Consolidated sheet.
2. Click on Data > Consolidate option.
3. The Consohdate dialog box will appear.
4. Choose the Sum function.
5. Select Data Source ranges respectively and click on Add button.
6. Click on OK button,
Output:
s.No | Product | Sales
. 1/Pen 100|
- 2Pencil 150|
3|Era.1er Iﬂ{ﬂ
alsketch Pen 400|
5|Water Colours 100|




5|Water Colours




Assignment 2

Objective: Applying subtotal in LibreOffice Cale
Task: Prepare a worksheet as following

Project Name Task Name

: Markebing Market Research

1 Marketing Content Creation
« Marketing  Social Media Planning
3 ?Mariu:ting Campaign Analysis
+ ProductDev  Prototype Development
i |Product Dev Quality Assurance
i ?Devehpn'hent User Interface Design

: Customer Sve  Service Improvement

w ‘Customer Sve  Ticket Resolution

n Customer Sve  Customer Feedback

1« Financial Budget Analysis

12 Iﬂzscarch Financial Reporting
Investment Planning

= Development  Market Trends Analysis

» Research Data Collection

n Research Research Paper Writing

Apply subtotal and find the sum of days required for project name.

Solution:
. Open spreadsheet software and enter the data.

Select the data,
Click on Data = Subtetal. The Subtotal dialog box appears.

Select column Project Name in Group By option.

e s o

Now mark the column to Days Required to count the no. of days required for each project.

Select the sum function sum from Use Function option.
Click on OK button.

S




A

Project Name

pment
pment

IFimrl-l:inI

Financial

1 wmm
12 Marketing

13 Marketing
14 Marketing
Marketing

Product Dev
Product Dev

v

Research
Research
Research

Task Name

User Interface Design
Market Trends Analysis

Budget Analysis
Investment Planning

Market Research
Content Creation
Social Media Planning

Campaign Analysis

Prototype Development
Quality Assurance

Financial Reporting
Data Collection
Research Paper Writing

C D

.L"-.',-;ﬁigrwd to | Days Required
m
Gabriel 25
23




Assignment 3

Objective: Link data and Spreadsheet
Task: Prepare a worksheets as following:

1. Enter the data such as Roll no. GR. NO, First Name, Last Name. Date of
Birth. Father Name. Mother Name. Enter records for at least 10 students.

2. Rename this worksheet as "Student Profile”.

3. Insert 3 new worksheets and rename as "PT2", "PT2" and "PT3" respectively.

4. In the PT1 worksheet create a reference for Roll No. First Name, and Last
Name columns from Student Profile by using the keyboard.

5. In the PT2 worksheet create a reference for Roll No, First Name, and Last Name
columns from Student Profile by using the mouse.

6. In the PT3 worksheet create a reference for Roll No, First Name, and Last Name
colunms from Student Profile as you wish.

Solution:
Open Excel and create a new workbook.

In the first worksheet, enter the data.

Right-click on the sheet tab (usually named “Sheet1™).

Select “Rename” and change the name to “Student Profile”.

Insert three new worksheets by clicking the “+” icon at the bottom.

Rename them to “PT1”", “PT2", and “PT3" respectively.

Go to the “PT1” worksheet.

In cell Al. type =Student Profile! A1 to reference the Roll No from the “Student Profile™ sheet.
Drag the fill handle to copy the formula down for all 10 students.

10. Repeat the process for First Name and Last Name columns.

11. Go to the “PT2” workshest.

12. Click on cell A1, type =. then navigate to the “Student Profile” sheet and click on cell Al.

o oo G o B

[Tvpe herel



13. Press Enter to create the reference.

14. Drag the fill handle to copy the formula down for all 10 students.

15. Repeat the process for First Name and Last Name colummns.

16. Go to the “PT3" worksheet.

17. You can use sither the keyboard or mouse method to create references for Roll No, First
Name. and Last Name columns from the “Student Profile™ sheet.

Output:
# | " | 3 I i | ¥

'|Roll No |GR NO [First Name [Last Name |Date of Birth |Father Name muﬂwr Name
1 1001 |Aarya |Sharma  |01/01/2010 [Rajesh Sunita
2 1002 |Bhavesh |Patel 102/02/2010 |Kiran Meena
13 1003 |Charu IMehta  |03/03/2010 |Anil Rekha
‘14 1004 |Dev Joshi |04/04/2010 [Suresh |Anita
/|5 1005 |Esha IDesai l05/05/2010 |[Ramesh |Lata
16 1006 |Farhan  |Khan |06/06/2010 |Imran Ayesha
7 1007 |Gauri IShah [07/07/2010 [Mahesh IPooja
/|8 1008 |Harsh Trivedi  |08/08/2010 |Naresh Kavita
9 1009 |isha \Bhatt |09/09/2010 |Prakash INisha
10 1010 ai |Patel 10/10/2010 |[Mukesh Seema
RollNo  |First Neme . lLast Neme
‘i |Aarya Sharma
2 [Bhavesh |Patel
‘ |Charu Mehta
4 |Dev Joshi
' (5 |Esha \Desai
6 |Farhan Khan
7 |Gauri IShah
.8 [Harsh Trivedi
" [isha Bhatt
10 Jai Patel




Assignment 4

' Task:

1. Insert hyperlink from the internet.
2. Insert hyperlink email.

3. Insert hyperlink of existing file.

4. Insert hj_?perlink of new file.

Insert H:i'pei'link from the internet

1. Type the text — NCERT Solution IT Class 10.

Click on Insert > Hyperlink option. Hyperlink dialog box wall open.
3. Click on Internet and type the URL.

4. Set the behaviour of link by selecting frame and target,

5. Click on OK button.

| ]

Insert Hyperlink Email

. Type the text — Gmail in the cell.

Click on Insert > Hyperlink option.

Select Mail option.

Type the recipient mail 1d in Recipient box.

Type Subject in Subject box.

Set the behaviour of link by selecting Frame, Target and Name.
Click on Apply and OK button.

Ne A R W e

Insert hyperlink of existing file

. Type the text: File - Document
Click on Insert > Hyperlink option.
Choose Document button.

Select the file from Path option. Either type the path or select the file using browse button.
Set target of link.

o kW

Apply settings required such as Frame, Name and Text.




1.
2.
3
4,
3
6.

7. Click on Apply and OK button.
Inserting Hyperlink of New Document

Type the Text — New Document.

Select option as Edit Now.

Type Filename in File box.

Select File Type as Text Document.
Apply settings such as Frame, Name etc.
Click Apply and OK button.

Qutput:

e o g s =

' INCERT Solutions IT Class 10

: IGmail Link

s [File — Document

G
-New Document




Assignment 5

Objective: Goal seck Application
Task: Enter data to obtain total net profit and set the goal to achieve total net profit of I
23.000 by changing the August month gross profit.

Sample Data:
Month Gross Profit | Net

April 20000 1294 2400
May 30000 144 4200
June 40000 11% 4400
July 25000 150 3750
August 35000 184 6300
Total 21050
Solution:

1. Enter data and prepare the spreadsheet along with formula.

2. Place the cursor in D7 cell.
3. Click on Tools > Goal Seek option. The Goal Seek dialog box will appear.
4. Move the cursor in Target Value box and enter the value — 23000,
5. Now select the cell as a variable cell,
6. Click on OK.
7. It will display the value obtained by Goal seek. If you wish to insert it in the
spreadsheet click on Yes. otherwise No.
Output:
A B 7 F E | F & |
1 Month Gross Profit 1 !
o % T T A |
3 May 3000 149 4200
& lure 40000 115 4400
5 iy 25001 159 aan
b Yugusl 35000 18%5 6300
I —— " N 2105
g
3 Goaal Sand
E Defoult Settings Libearfice Caic (|
%- Fomnula well;  SD57 = @ vaoal Seck surreodden, Besdr 453833.3333333333 H
Bl Tmerysa: 5000 Insort The i<t intn The wndahie rell?
:: Vanakle cell:  E%0 i I
|
15 | Heip LK, ancz! | = e |
17 - = = I

18 - https:/inavodayateacher.com/




Unit 3
Database Management System

Assignment 1

Objective: Steps to create a table using table wizard

Task: Create a table using wizard and insert data.

Solution:
1. Click on Start -» All Programs -» LibreOffice 24.2 - LibreOffice Base. 24.2 LibreOffice
Base window will open with Database Wizard.

Click on Create a new database option.
Click on Next button.

Select the database Register option erther Yes, or No.

b

L

Check on Open database for editing.

Click on Finish button.

It wall prompt to save the database.

Type the desired name and save it. I have given dbl.

Now click on Tables button from Left pane and choose the option - Use Wizard to Create
Table... from the tasks window.

e

10. The Table Wizard will open. Follow wizard steps to create a table.

11. In first step of wizard select the Category either Business or Personal.

12. Now choose a table from hst of table. As I have selected Employees table.

13. Click on Next and select field types and all if you want to change it. Click on Next. I have
selected EmployeelD, Firstname. Lastname. Salary, Datelured.

14.Set a primary key for your table in this step. Click on Use an existing field as a
Primary Key. | have selected EmplyeelD as Pnmary key. Click on Next.

15. If you wish to change the table name then type new name for the table and click on Insert.

19 - https:/inavodayateacher.com/




Data immediately, and click on Finish.
16. Enter data now.

Ei Employees - db1 — LibreOffice Base: Table Data View
file Edit View Insert Dats Tools Window Help

| Er;';pluweID \ Firstname \ Lastname \ Salary | DateHired \

111 Tanmay Patel 25000  04/01/18
T Chetna  Patel 28000 0500118
BT Swesh  Chauhan 27000 08/02/19
e dhea  Dabi 3000 090420




Assignment 2

Objective: Query creation using wizard

Task: Create table Marksheet (Using SQL Command) and perform the bellow given
quertes using wizard and design view.

Field Name Data Type Size
Stud No Integer 2
Name Text 15
RollNo Integer 3
Subl01 Decimal 3.2
Subl102 Decimal 3.2
Subl03 Decimal 3.2

1. In the Database file Add these Fields: (Total: Datatype- Number 3 digits, Percentage: Datatype
- Number 3 digits with 2 decimal places. Grade: Datatype- Char with 2 letters)

2. Insert more 3 records in MARKSHEET using SQL mode.

3. Display name, rollno. marks of 3 subjects, total and percentage using design view.

4. Display name. rollno, grades from the marksheet table using query wizard.

5. Display the maximum marks for Sub101 and minimum marks for Sub102 using design view.

6. Display the rollno, name and percentage whose percentage are more than 70 using design view.,

7. Display all the record in ascending order of names using design view.

Solution:

create table “marksheet”
(“Stud_no™ tinyint primary key.
“Name” varchar(15),

“RollNo™ tinyint.

“Subl101™ decimal(5,2),
“Sub102” decimal(5,2),
“Sub103” decimal(5.2)) :




Output:

. 67 ol |LireCrifee o
fle Edit View Insen Tools Window Help

p-m-B-aaliD- 0o nEE ERA

e

8 Create Table in Design View..
& Use Wizard to Create Table.
9 Create View..
Crerias
Ferms
i=

| marksheet - db1 — LibreOffice Base- Table Data View - o »
Fle Edit View Imsert Data Tools Window Help =t
B X R 20- B TEYIRQR

Swdno | Name | RoliNo | Swiol | swioz | Subiod |
s 1112 Dhrva 4 57.00 65.00 8400

1 _of1

e

‘ 9 Empioyees

Steps to perform a query using design view

1. Click Queries - Create Query in Design View....
2. The query design window will open.

3. Select the marksheet table and click on Add button.
4

. Now select fields given in the question like name. rollno. marks. Sub101, Sub102, Subl103,
Total and Percentage.

5. Save the query.




Output:
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Query Result:
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Query Wizard Steps
1. Click on Queries > Use Wizard to Create Query...
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Hle Edit
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3. Select the table marksheet and select the fields given the question.

Curery Wizarc
Steps
Select the fialds (columns) for your query
| e seston T
2 Sorting order llublcmrlfshcct il
3. Scarch conditions '
4 Delail Lo sutiinaly !ﬂ._\:ulnl:lc fiekds lds in the Query;
T RolNo marksheet.stud_no
— ! Sub1 markshaelName
& rouging condifions Sulr102 matkshieel Percentaye
7 Aliases ‘Ed:r‘l 33 »  marksheet.Grade
£ Twverview = )

|
|
"~

I
Help < Back Wext = Firish Cancal
4. ‘Click Go Finiah,
ﬁ Query marksheet - db1— Jbredfce Base: Tablz Dzta View = & X

Fle Edit Yiew Insert Date Tools Window Help

Bl Y RE 2LIC-BNLIYTVIR
| Studno | Name  Percertage | Grade
| AL Sagar 3800 B




=
Design View

2 Display maximum marks and minimum marks for the fields given in the
question. USINg desien view.

1. Click Queries = Create Query in Design View....

2. The query design window will open.

3. Select the marksheet table and click on Add button.

4. Now select the field Sub101 and Subl02.

5

6

. Choose the function maximum under SubI01 and Minimum under Sub102.
. Save the query and check the result.

Query Design:
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Assignment 3 (Query using criterion and sorting)

—

Dasplay the rollno, name and percentage whose percentage are more than 70 using design view

Click Queries - Create Query in Design View....

The query design window will open.

Select the marksheet table and click on Add button.
Select columns given in the question 1.e. Rollno, Name and Percentage.
Type =70 1n the front of eriterion under the percentage field.

6. Save the query and check the result.

Query Design:
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—

Display all the record in ascending order of names using design view.

The query design window will open.

Select sort - ascending under name field.

e 35 B i o

. Save the query and check the result.
Query Design View

[ dbtcdb . Ouery| — LibvatMce Base: Cuzry Dasign
Fie it Mew Insem Taols Window  Halp

mE % o alik

B-5 xnni2-
:

Click Quenies > Create Query in Design View....

Select the marksheet table and click on Add button.
Select markesheet.* and name in the column list.

Wow click on Visible checkbox to hide the name column in result.
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Learning Outcome — Create Forms and Reports using wizard
Assignment 4

Objective: Creating form using wizard
Task: Create table a form using wizard by selecting all the fields for the table - Marksheet

Solution
Steps to create a form using wizard
1. Click on Forms =» Use Wizard to Create Form...

By dotadb  LsweOffioe Base
bl abl Yo Drmed ek Wedow Lieip

B.Bi-FH- % B I N.80-BERER
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-l-n jie Creabe Foronin Do View.
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2. A Form Wizard appears.
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3. Select the table from Tables or Queries then add all the fields.
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4. Click on Next button. Ignore step 3 and step 4 from wizard.
5. Select the first option i.e. Columnar — Labels Left then click on the next button.
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. Now set data entry step will be there. Ignore this step and click on Next. Choose the styles for
the form interface and click on next.

b | LhraiCTipe D ]
file Tl Vs lmen Tormel Spdes Table  Tom e Wisko ikl
F'..u -H. "'_E] t|' 3 _-;'|-II|.T _-E-:'E H"I:..'ﬁ' '|| :-.--I_|"'-|3‘| -j_l'.l > .
Muiaall Pusaraih 2w vl et Snd SRt B T W% |¥ 5% i' ¥4E T T E T elE T _E _E
B 1 1
e
F
By 1 Siyie ST e Taim
=
K| i i Aot ek
Ao
i oD |
1he Gy
I (E1, 1
» £ Froirep vy Tedrage
o] J||1-
=1 & Ser it vy =)
=] [ fiuke e At
; Gl nare il
= skt
=l
|
.
T

7. Type new name for the form and click on work with the form. Click on Finish
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Form Output:
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As ent 5

Objective: Creating report using wizard
Task: Create table a report using wizard by selecting all the fields for the table - Marksheet
Solution

1. Click on Reports - Use Wizard to Create report. The report wizard will open in the
new window.
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2. Select the table and add fields.
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3. Now change the label text that you want in the report. | have changed the label
Stud no into Adm. No. Click on Next.
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4. [ have skipped groping and sorting options by click on Next button.
5. Now choose the layout. I have selected Columnar. Single Column as Layout of
Data, Landscape Onientation and Click on Next,
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6. Now type the title of the report and select dynamic report > Create report now option.
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7. Now click on finish.
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